AkvaH2O
21.06.2022 22:12

1.Составить программу, которая выводит сообщение о своих возможностях : Введите номер необходимой функции:
1-квадрат; 2-корень квадратный; 3-синус; 4-косинус
и считает соответствующую функцию для введённого с клавиатуры числа.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
pallnash
29.12.2020 22:38

#include <iostream>

#include <cmath>

#include <conio.h>

using namespace std;

int main() {

   cout << "Введите номер необходимой функции:\n1-квадрат; 2-корень квадратный; 3-синус; 4-косинус\n";

   char c;

   cin >> c;

   // Если используешь обычный компилятор (не онлайн), можно написать "char c = _getch()";

   

   cout << "Введите число: \n";

   int num;

   cin >> num;

   

   switch(c) {

       case '1':

           cout << pow(num ,2);

           break;

       case '2':

           cout << sqrt(num);

           break;

       case '3':

           cout << sin(num);

           break;

       case '4':

           cout << cos(num);

           break;

       default:

           cout << "Ошибка ввода";

   }

   return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота