Amdrek
03.04.2022 00:30

Кто знает паскаль Некоторая семья решила отдохнуть на море в июне месяце в течение 10-и дней. Они могут приобрести билеты только в первый день каждой декады месяца (т.е. 1-го июня, 11-го июня, 21-го июня). Данные о прогнозе погоды в июне хранятся в текстовом файле vreme.in.

Задача: Напишите программу, которая определяет декаду июня месяца с наибольшим количеством солнечных дней. Программа будет содержать подпрограмму с именем PS с целым параметром – начало декады июня (1, 11 или 21). Подпрограмма возвратит количество солнечных дней соответствующей декады.

Ввод: Текстовый файл vreme.in содержит для каждого из 30-ти дней июня по одной букве, которая соответствует погоде соответствующего дня: ‘S’ – солнечно, ‘N’ - облачно, ‘P’ – дождь.

Вывод: Текстовый файл vreme.out содержит две строки – в первой записаны два целых числа, разделенных дефисом – начало и конец периода отдыха. (Например: 1-10, 11-20 или 21-30), и во второй строке – количество солнечных дней в этом периоде.

Примечание. Все три декады июня имеют разное количество солнечных дней.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Vladosik0987
14.12.2022 10:01
Выполняя алгоритм, получаем следующий результат (15 итераций)

1. 0..65534 -> 32767
2. 0..32766 -> 16383
3. 0..16382 -> 8191
4. 0..8190  -> 4095
5. 0..4094  -> 2047
6. 2048..4094 -> 3071
7. 2048..3070 -> 2559
8. 2560..3070 -> 2815
9. 2816..3070 -> 2943
10. 2944..3070 -> 3007
11. 2944..3006 -> 2975
12. 2976..3006 -> 2991
13. 2992..3006 -> 2999
14. 3000..3006 -> 3003
15. 3000..3002 -> 3001

Если лень перебирать вручную, можно воспользоваться программой

var k,l,r,x,f:integer;
begin
f := 3001;
l := 0;
r := 65534;
x := (l + r) div 2;
k := 1;
while (x <> f) and (l < r) do
  begin
  writeln(k,' ',l,' ',r,' ',x);
  k := k + 1;
  if f < x then r := x - 1
    else l := x + 1;
  x := (l + r) div 2
  end;
writeln(k,' ',l,' ',r,' ',x);
end.
0,0(0 оценок)
Ответ:
feliz3600
17.11.2020 18:03
// PascalABC.NET 3.0, сборка 1144 от 16.01.2016
begin
  var n:=ReadInteger('n=');
  var a:=ArrRandom(n,-50,50);
  Writeln('Исходный массив'); a.Println;
  var se:=a.Where(x->x mod 3=0);
  if se.Count=0 then
    Writeln('В массиве нет элементов, кратных трем')
  else begin
    var b:=se.Max;
    var i:=0;
    while a[i]<>b do Inc(i);
    if i=n-1 then Writeln('Максимальный элемент - последний')
    else begin
      Writeln('Результирующий массив');
      a[i+1]:=abs(a.Where(x->x<0).Sum); a.Println
      end
    end
end.

Тестовое решение:
n= 15
Исходный массив
-24 -38 15 -33 -40 -18 21 34 20 49 -19 29 29 38 -41
Результирующий массив
-24 -38 15 -33 -40 -18 21 213 20 49 -19 29 29 38 -41
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота