anytka260602
26.01.2022 03:58

Программа на С++.
Ввести строку и слово. Определить сколько раз слово встречается в строке.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
базлайдер
13.05.2020 19:11

Билеты на общественный транспорт обычно имеют шестизначные номера. Некоторые из этих билетов считаются “счастливыми”. Для того, чтобы определить, является ли билет “счастливым”, нужно сложить 3 первые и 3 последние цифры номера. Если суммы будут одинаковыми, билет считается “счастливым”. Например, левый билет на рисунке не “счастливы”, потому что 2 + 2 + 8 = 12, а 7 + 1 + 7 = 15. Суммы не совпадают. Написать программу, которая будет вводить номер билета и говорить является ли он счастливым или нет. При выполнении задания учитывайте, что операция вычисления остатка от деления на 10 всегда дает нам последнюю цифру числа, например: 145 % 10 = 5.

2)

Написать программу, которая будет вводить с клавиатуры положительные числа до тех пор, пока не будет введена -1. Все числа должна записываться в список и в конце работы программы из списка должна быть распечатаны сначала четные, затем нечетные числа.

0,0(0 оценок)
Ответ:
Brynd
21.04.2022 17:12

1)

var

s,r:string;

i:integer;

begin

readln(s);

r:='';

for i:=1 to length(s) do

if s[i]<>'a' then r:=r+s[i];

writeln(r);

end.

2)

текст разделяем знаками препринания


var
t: array [1..100] of string;
p, s, r: string;
f, i, j, k: integer;

begin
p := ' ,.!?;:-';
readln(s);
k := 0;
r := '';
for i := 1 to length(s) do
begin
f := 0;
for j := 1 to length(p) do
if s[i] = p[j] then f := 1;
if f = 0 then r := r + s[i]
else
begin
k := k + 1;
t[k] := r;
r := '';
end;
if i=length(s) then
begin
k := k + 1;
t[k] := r;
end;
end;
for i := k downto 1 do
write(t[i], ' ');
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота