lunagatina04
04.04.2021 13:05

Язык - PascalABC *ограничение по времени на тест: 1 секунда

*ограничение по памяти на тест: 256 мегабайт

*ввод: стандартный ввод

*вывод: стандартный вывод

В строке записана информация о количестве притоков рек.

Вывести название реки у которой наибольшее число притоков. Если таких рек несколько, то вернуть название последней из них.

Гарантируется, что в строке есть информация хотя бы об одной реке.

Входные данные

Дана строка, состоящая из слов. Под словом будем понимать последовательность любых символов (кроме пробелов), ограниченную пробелами или стоящую в начале или конце строки. Между словами, а также в начале и конце строки, может быть один или несколько пробелов.

Слово в данной строке – это _ .

Количество притоков – это целое, не отрицательное число, меньшее 10000.

Выходные данные

Название реки.

For example:

Input:

Lena_4 Yenisei_5 Volga_3

Result:

Yenisei

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Пофиг11
16.05.2023 16:41

var

 x, y, a, b, c, D, x1, x2: real;

 inp: string;

 inp_arr: array of string;

begin

 writeln('a b c');

 readln(inp);

 inp_arr := inp.split(' ');

 a := StrToFloat(inp_arr[0]);  

 b := StrToFloat(inp_arr[1]);

 c := StrToFloat(inp_arr[2]);

 D := b*b - 4 * a * c;

 x1 := (-b + sqrt(D)) / 2*a;

 x2 := (-b - sqrt(D)) / 2*a;

 if x1 > x2 then x := x1

 else x := x2;

 if x < 0 then y:= (1 / (x + (sin(x)/(x*x+1

 else y:= (x*x-1)*sin(x)/(x*x*x);

 write('a:', a, ' b:', b, ' c:', c, ' x:', x, ' y:', y);

end.

0,0(0 оценок)
Ответ:
Iranmlp
03.06.2023 07:53

Вы можете создать простую формулу для с суммы, вычитания, умножения и деления значений на вашем компьютере. Простые формулы всегда начинаются со знака равной(=),за которым следуют константы, которые являются числами и операторами вычислений, такими как "плюс"(+),"минус" (- ),"звездочка"*или "косая черта"(/)в начале.

В качестве примера рассмотрим простую формулу.

Выделите на листе ячейку, в которую необходимо ввести формулу.

Введите = (знак равенства), а затем константы и операторы (не более 8192 знаков), которые нужно использовать при вычислении.

В нашем примере введите =1+1.

Примечания:

Вместо ввода констант в формуле можно выбрать ячейки с нужными значениями и ввести операторы между ними.

В соответствии со стандартным порядком математических операций, умножение и деление выполняются до сложения и вычитания.

Нажмите клавишу ВВОД (Windows) или Return (Mac).

Рассмотрим другой вариант простой формулы. Введите =5+2*3 в другой ячейке и нажмите клавишу ВВОД или Return. Excel перемножит два последних числа и добавит первое число к результату умножения.

Объяснение:

вот это вроде бы то

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота