nik2004g
05.06.2021 18:18

( Python ) Напишите программу, которая заполняет массив из 20 элементов случайными числами на отрезке [0;20] и находит:

1) Отдельно сумму элементов в первой и во второй половинах массива.

2)Произведение ненулевых элементов

3) Количество отрицательных элементов массива

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
nutswai
04.03.2021 17:39

from random import randint

# заполняем массив случайными числами

arr = [randint(-10,10) for i in range(20)]

print(arr)

# задание 1

print(f'Сумма элементов первой половины массива {arr[0:10]} равна {sum(arr[0:10])}')

print(f'Сумма элементов второй половины массива {arr[10:20]} равна {sum(arr[10:20])}')

# задание 2

k=1

for i in arr:

   if i!=0:

       k*=i

print(f'Произведение ненулевых элементов массива равно {k}')

# задание 3

k=0

for i in arr:

   if i<0:

       k+=1

print(f'Количество отрицательных элементов массива равно {k}')

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота