1)Чему равно среднее арифметическое значений элементов массива a[3] и a[4], сформированного следующим образом: for i:= to 10 do if i mod 2 = 0 then a[i]:=i/2 else a[i]:=(i+1)*2; (оформите массив в виде таблицы) 2)Массив а из десяти элементов сформирован следующим образом: for i:= to 10 do a[i]:=3*i-6; к данному массиву был применен следующий алгоритм: b:=a[10] for i:= to 10 do a[10-i]:=a[9-i]; a[1]=b; Чему равно значение седьмого элемента обработанного массива (Оформите оба массива в виде таблиц)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
5867389576M
13.01.2021 12:43
В задании не указано - требуется ли использовать форму или нет. Вариант документа с формой:
<HTML>
<HEAD>
<SCRIPT>
<!--
function btnClick(n)
{
 if (n>5) r=n*n;
  else if (n<5) r=n-2; else r=Number(n)+1;
 document.frm.res.value=r;
}
//-->
</SCRIPT>
</HEAD>
<BODY>
<H1>Документ с JavaScript</H1>
<FORM name=frm>
Введите число
<INPUT type=text name=num size=5 value=0>
<INPUT type="button" name="bt" value="Щелкни здесь!"
        onClick="btnClick(num.value);">
Результат:
<INPUT type=text name=res size=5 value=0>
<BR><INPUT type=reset VALUE="Сброс">
</FORM>
</BODY>
</HTML>
0,0(0 оценок)
Ответ:
glebyha22
03.01.2021 00:15
Program matrix;
var  A: array[1..10, 1..10] of integer;
i, j, mini, minj, maxi, maxj, temp: integer;
begin  Randomize;
  for i := 1 to 10 do  begin
    for j := 1 to 10 do    begin
      A[i, j] := random(100);
      write(A[i, j], ' ');
   end;
   writeln;
   end;
   mini := 1;
   minj:=1;
   maxi := 1;
   maxj:=1;
   for i := 1 to 10 do 
   for j := 1 to 10 do
    begin 
     if A[i, j] < A[mini,minj] then  begin 
      mini := i;
      minj := j;
     end;
      if A[i, j] > A[maxi,maxj] then      begin
       maxi := i;
       maxj := j;
      end;
      end;
      WriteLn('min = ',A[mini,minj],' это ',mini,' ряд ',minj,' столбца.' );
      WriteLn('max = ',A[maxi,maxj],' это ',maxi,' ряд ',maxj,' столбца.' );
       temp := A[maxi, maxj];
       A[maxi, maxj] := A[mini, minj];
       A[mini, minj] := temp;
       writeln;
       for i := 1 to 10 do  begin
        for j := 1 to 10 do
         write(A[i, j], ' ');
         writeln;
       end; 
       readln;
       end.
temp - переменная для временного хранения минимальных и максимальных элементов.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота