89640197456
20.03.2023 08:49

Задача В»: Напишите программу, которая заполняет матрицу
случайными числами и находит максимальный
элемент матрицы и его индексы (номера строки и
столбца).
Пример:
Матрица А:
12 34 14 65
71 88 23 98
87 46 53 39
76 58 24 92
Максимум: A[2 ,4] = 98
сделать нужно в Python.​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
FaizTimYr
29.10.2020 07:11
Сначала надо найти аналитическое решение задачи.
Определить координаты точек пересечения двух функций - это совместно решить уравнения, описывающего функции.
\begin {cases} y=x^2+c \\ y=kx+b \end {cases} \to x^2+c=kx+b \\ \\ x^2-kx+(c-b)=0 \\ D=k^2-4(c-b) \\ \displaystyle x_{1,2}= \frac{k\pm \sqrt D}{2}; \quad y_{1,2}=kx_{1,2}+b
Теперь можно составить программу, предусмотрев в ней анализ случаев D<0, D=0 и D>0.

uses Crt;
var
  k,b,c,x1,x2,y1,y2,d:real;
begin
  ClrScr;
  Write('Введите через пробел c,k,b: '); Read(c,k,b);
  d:=sqr(k)-4*(c-b);
  if d<0 then Writeln('Точек пересечения нет')
  else
    if d=0 then begin
      x1:=k/2; y1:=k*x1+b;
      Writeln('Координаты точки пересечения (',x1:0:4,',',y1:0:4,')')
    end
    else begin
      d:=sqrt(d);
      x1:=(k-d)/2; y1:=k*x1+b;
      x2:=(k+d)/2; y2:=k*x2+b;
      Writeln('Координаты точек пересечения:');
      Writeln('(',x1:0:4,',',y1:0:4,'), (',x2:0:4,',',y2:0:4,')')
    end;
  ReadKey
end.

Тестовые решения:
Введите через пробел c,k,b: -2 1 1
Координаты точек пересечения:
(-1.3028,-0.3028), (2.3028,3.3028)

Введите через пробел c,k,b: 1 3 -5
Точек пересечения нет

Введите через пробел c,k,b: 12 6 3
Координаты точки пересечения (3.0000,21.0000)
0,0(0 оценок)
Ответ:
Colaps
22.04.2023 17:10
Для мене зручна клавіатура це рівно розприділені функціональні клавіші на обидві сторони клавіатури для швидшої роботи з ПК. Розкладку клавіатури я вважаю залишити такою ж, бо вже звик до такої і вона мені найбільш зручна. Хотілось би, щоб розміщення клавіш було рельєфним для зручнішого і швидшого друку тексту. Мала ложе під зап'ястя щоб руки менш втомлювались. І мала сантиметровий підйом над столом, щоб у випадку потрапляння рідини на стіл не була пошкоджена. Дуже зручно було б мати USB порт для зручної роботи з флешками і мала додаткові регулюючі софт клавіші при натисканні яких вмикалась вибрана програма. Ось це була б найзручніша клавіатура для мене.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота