stasamaca
18.01.2020 14:38

Дан массив a, состоящий из n целых неотрицательных чисел. Ваша задача — построить по нему массив b такого же размера, задающийся следующей формулой: bi=(a2i,2⋅ai,где i — четное число;где i — нечетное число.)

Оба массива нумеруются, начиная с 0 (например, массив a имеет вид a0, a1, a2, ..., an−1).

Формат входных данных
В первой строке входных данных находится натуральное число n — количество элементов массива (n≤500).
Во второй строке вводятся n целых неотрицательных чисел, разделённых пробелами — элементы этого массива. Элементы массива не превосходят 1000.

Формат выходных данных
Выведите на экран n целых неотрицательных чисел, разделённых пробелами — элементы массива b.
входные данные
4
1 3 3 7

5
4 20 412 3 2
выходные данные
1 6 9 14

16 40 169744 6 4

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Софья909
11.10.2020 20:00

#include <iostream>

using namespace std;

int main()

{

setlocale(LC_ALL, "Rus");

int n, a;

cout << "Введите месяц ";

cin >> n;

cout << "Введите высакосный год ";

cin >> a;

switch (a) {

case 0: {

 if (n == 1 || n == 3 || n == 5 || n == 7 || n == 8 || n == 10 || n == 12) {

  cout << "31 день";

 }

 else

  if (n == 4 || n == 6 || n == 9 || n == 11) {

   cout << "30 дней";

  }

  else {

   cout << "28 дней";

  }

 break;

}

case 1:

{

 if (n == 1 || n == 3 || n == 5 || n == 7 || n == 8 || n == 10 || n == 12) {

  cout << "31 день";

 }

 else

  if (n == 4 || n == 6 || n == 9 || n == 11) {

   cout << "30 дней";

  }

  else {

   cout << "29 дней";

  }

 break;

}

}

return 0;

}

Объяснение:

0,0(0 оценок)
Ответ:
fursatana0
25.03.2020 00:05

1,2,3,4,5,6,8

Объяснение:

Что напечатается:

1

3

5

6

2

4

6

8

4

6

8

При вызове F(1) печатается 1. Дальше вызовется F(3)

Напечатается 3. Вызовется F(5)

Напечатается 5. F(7) не вызывается, т.к. 7>5

Теперь вызывается вторая функция для F(3), то есть F(6)

Печатается 6. Дальше вызывается вторая функция для F(1), то есть F(2)

Печатается 2. Вызывается первая функция для F(2), т.е. F(4).

Печатается 4. Вызывается первая функция для F(4), т.е. F(6).

Печатается 6. Вызывается вторая функция для F(4), т.е. F(8)

Печатается 8. Вызывается вторая функция для F(2), т.е. F(4)

Печатается 4. Вызываются первая и вторая функции F(6) и F(8)

Печатается 6

Печатается 8

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота