газмадошка4
10.09.2020 01:00

там есть ошибки если что Составьте программу, выводящую на экран квадраты чисел от 10 до 20 включительно.

1
2
3
4
5
6
7
int main()
{
for (int i=10; i<=20; i++)
cout<<i*i<<" ";
cout<<endl;
return 0;
}​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ma220299
22.07.2021 00:04
Сначала переведём 8см в дюймы (т.к. разрешение сканера указано в точках на дюйм- dpi ):
8см / 2,54 ≈ 3,15 дюйма
Значит, в одной стороне изображения поместится:
1400 * 3,15 = 4410 точек
Далее, вычислим информационный объём файла. Для этого количество точек во всём изображении умножим на глубину цвета (это количество информации, нужное для кодирования одной точки изображения):
4410 * 4410 * 8 = 155584800 байт
Переведём в мегабайты, дважды поделив на 1024 (или один раз на 2 в 20 степени):
155584800 / 1024 / 1024 ≈ 148,38 МБ
0,0(0 оценок)
Ответ:
ученикпро1
04.01.2023 07:38
Перевод делается отдельно для целой и дробной части числа.

1) переводим целую часть числа:
для этого делим её нацело (т.е. вычисляем частное и остаток) на основание желаемой системы (на 8):
32 / 8 = 4 (и 0 в остатке)
продолжим деление для частного (4)
4 / 8 = 0 (и 4 в остатке)
далее делить не чего, т.к. частное равно нулю
из полученных остатков составляем восьмеричное число 40₈  (это целая часть нашего числа в восьмеричной системе счисления).

2) переводим дробную часть числа:
для этого умножаем её на основание желаемой системы (на 8):
0,25 * 8 = 2
если бы ответ содержал дробную часть, то мы бы продолжили умножать дробную часть, на каждом шагу отделяя её от целой части
но, т.к. у нас результат умножения не содержит дробной части, то мы составляем полученные целые части ответов (у нас это цифра 2), и записываем полученный результат после десятичной запятой:  0,2₈ (это и есть дробная часть в восьмеричной системе счисления)

3) соединяем полученные целую и дробную часть вместе:
ответ: 40,2₈
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота