julija74
06.04.2022 05:50

Составить программу и блок-схему: Вводится натуральное число N. Написать программу для вычисления произведения N сомножителей: 1*3*5*7

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Арина200911
25.06.2021 06:12
1. Диапазоном.

   То есть, целое число может занимать, например, один байт, два или четыре байта. Число, которое занимает 1 байт( 8 бит ), может принимать значения от нуля то 255, то есть 2^8 = 256 чисел (до 255, потому что ноль - тоже число). Если прибавить к однобайтному числу 256, в нём сохранится 0 (каждый раз, когда происходит выход за границу диапазона - счёт начинается с нуля). То есть, и если прибавить 513, в числе сохраница единица.
   Если число занимает 2 байта, его диапазон 2^16 = 32767. Четыре байта - диапазон [0..4294967295].

2. Точностью хранимых в нём чисел (количество значащих разрядов), и диапазоном.

   То есть, например, переменная вещественного типа может занимать в памяти 4 байта, и при этом в нём может храниться число 1.23 * 10^35.
То есть в 4-х байтах целого типа можно хранить числа не больше 4294967295, а в 4-х байтах вещественного типа - в несколько десятков раз больше.
   Это возможно потому, что хранится не всё число, в только первые несколько значащих цифр. В 4-байтной вещественной переменной могут храниться числа [-3.4∙10³⁸ .. 3.4∙10³⁸], при этом количество значащих разрядов в нём всего 7-8(часть бит из этих 4 байт отводится для хранения степени 10).
0,0(0 оценок)
Ответ:
aiskfjdUe
21.07.2020 07:17
Программа работает при условии, что введённые числа целые.

#include <iostream>
#include <string>

using namespace std;

int main()
{
    string S,P;
    char c[10000] = "";
    int C,z;
    double R = 1;
    getline(cin, S);
    S+=' ';
    for(int i = 0; i<S.length(); i++)
    {
            if(S[i] != ' '){
                 if(S[i] == '-'){z = -1; i++;}
                 else z = 1;
                 C = 0;
                 while((S[i] >='0')&&(S[i] <= '9'))
                 {
                        C = C*10 + (S[i] - '0');
                        i++;
                 }
                 C = C*z;
                 R*=C;
                 itoa(C,c,10);
                 if (z == -1)
                 {
                       P+='(';
                       P+=c;
                       P+=')';
                 }
                 else P+=c;
                 P+="*";
            }
    }
    P[P.length()-1] = '=';
    int d,s;
    P+=ecvt(R,4,&d,&s);
    S = P;
    cout << S << "\n";
    system("Pause");
    return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота