Mashatry
20.12.2022 03:02

Информатика!Написать программу в Паскале! Номер 3.

Важно! Для решения задач использовать цикл с постусловием! ​


Информатика!Написать программу в Паскале! Номер 3.Важно! Для решения задач использовать цикл с посту

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
lvalerika
10.12.2021 20:54
Program z18;  Var a: array [1..1000] of string; i,j,l,min,h:integer; s:string;Begin  write('Введите строку - '); readln(s);  l:=s.Length;  i:= 1;  j:= 1;    while i <= l do  begin    while (s[i] <> ' ') and (i <= l) do    begin      a[j]:=a[j] + s[i];      i:= i + 1;      if (i > l) then break;    end;    j:= j + 1;    i:= i + 1;  end;    i:= 2;  min:=a[1].Length;  while (a[i] <> '') do  begin    l:=a[i].Length;    if (l < min) then h:= i;    i:= i + 1;  end;  writeln(a[h]);End.

Program z19;  Var a: array [1..1000] of string; i,j,l,min:integer; s:string;Begin  write('Введите строку - '); readln(s);  l:=s.Length;  i:= 1;  j:= 1;    while i <= l do  begin    while (s[i] <> ' ') and (i <= l) do    begin      a[j]:=a[j] + s[i];      i:= i + 1;      if (i > l) then break;    end;    j:= j + 1;    i:= i + 1;  end;    i:= 1;  while (a[i] <> '') do  begin    if ((a[i] = 'мое') or (a[i] = 'Мое')) then a[i]:= 'наше';    write(a[i], ' ');    i:= i + 1;  end;End.
0,0(0 оценок)
Ответ:
kirilsex69
05.11.2022 00:11
1) монитор, клавиатура, мышь, сканер, принтер,колонки..
2)процессор – сердце каждого компьютера. Именно процессор выполняет инструкции программного обеспечения, использующегося на персональном компьютере, обрабатывает набор данных и производит сложные вычислительные операции. Главными характеристиками процессора являются: производительность, тактовая частота, энергопотребление, разрядность, архитектура и кэш.
3) Монитор – это специальное устройство для вывода информации с вычислительного блока компьютера посредством использования специального экрана, оборудованного либо электронно-лучевой трубкой (ЭЛТ), либо жидкокристаллической матрицей (ЖК, используется в современных моделях мониторов).
Экран монитора с ЭЛТ обновлялся с частотой до 85 Гц, что положительно влияло на глаза пользователя, снижая нагрузку.
Экран монитора с ЭЛТ обновлялся с частотой до 85 Гц, что положительно влияло на глаза пользователя, снижая нагрузку.
4) Жесткий диск, он же винчестер, является основным местом, где хранится вся информация. В отличие от оперативной памяти, он энергетически независим, поэтому можно хранить данные даже после выключения компьютера.
Первоочередная характеристика жесткого диска - несомненно, его объем. Чем он больше, тем лучше
5)Клавиши клавиатуры, в зависимости от их назначения и расположения, можно поделить на группы:-Алфавитно-цифровые;-Функциональные;-Блок дополнительных клавиш (цифровая панель);-Клавиши управления курсором;-Служебные (клавиши управления).
-Алфавитно-цифровые клавиши.
Назначение: ввод букв, цифр, знаков препинания и других специальных знаков. В эту категорию также относится клавиша SPACE (ПРОБЕЛ).
-Функциональные клавиши
Сюда относят клавиши F1-F12. За данными клавишами нет постоянных закрепленных функций (исключением является только клавиша F1, которая используется для получения справки). Эти клавиши, как правило, программируются уже пользователем для каждой программы отдельно.
-Блок дополнительных клавиш (цифровая панель)
Повторяют действие цифровых и некоторых знаковых клавиш основной панелиДаная панель может использоваться в двух режимах: * Ввода цифр; * Управления курсором.Переключения режимов осуществляется клавишей NUM LOCK
-Клавиши управления курсором
Курсор — экранный указатель, который показывает место ввода следующего символа (для текста) или текущую позицию (точку), к которой будет применяться действие мыши.Клавиши со стрелками служат для перемещения курсора на одну позицию по экрану монитора в соответствии с направлением.Клавиши PAGEUP и PAGEDOWN переводят курсор на одну страницу вверх и вниз соответственно, а клавиши HOME и END переводят курсор в начало и конец текущей строки.Клавиша INSERT переключает режима ввода данных: вставка и замена ( в режиме вставки новые знаки вводятся без замены существующих символов, а в режиме замены — заменяют).Клавиша DELETE удаляет знаки, которые находятся справа от текущего положения курсора, а клавиша BACKSPACE удаляет знаки, которые находятся слева от текущего положения курсора.
-Служебные (клавиши управления)
Enter (англ. Enter — «Ввод») — используется для перехода на новую строку (при наборе текста), подтверждения какого-то действия или готовности пользователя, выбора команды из меню.Клавиши CTRL и ALT – применяются в комбинации с другими клавишами (две сразу или отдельно) для выполнения определенной команды.Клавиша SHIFT – клавиша-модификатор. Используется для ввода прописных (заглавных) букв (при одновременном нажатии клавиши Shift и клавиши с буквой), а также знаков препинания. Применяется также в комбинации с другими клавишами клавиатуры (а также мышью) для выполнения различных команд.Клавиша ТАВ. Выделяют две основные функции клавиши ТАВ: - вводит в текст символы табуляции (вставка пустых символов); - позволяет поочередно переключаться между элементами управления в пределах одного окна.Клавиша ESC — предназначенная для возврата к предыдущему состоянию или (не всегда) выходу из приложения или программы.PRINT SCREEN — печать, текущего состояния экрана на принтере. Также сохраняет изображение текущего состояния экрана в буфере оперативной памяти.Клавиша PAUSE/BREAK — предназначена для приостановки текущего процесса (программы).Клавиша CAPS LOCK – фиксирует режим ввода прописных (заглавных) букв. На клавиатуре имеется индикатор, который отображает состояние (вкл/откл) клавиши.Клавиша NUM LOCK – включение/отключение дополнительной цифровой панели. Индикацией включения режима служит один из трёх светодиодов на клавиатуре.Клавиша SCROLL LOCK. Когда режим Scroll Lock включён, клавиши курсора выполняют функцию передвижения экрана. На клавиатуре имеется индикатор, который отображает состояние (вкл/откл) клавиши.Клавиша WIN -используется для запуска кнопки ПУСК ОС Windows. В комбинации с другими клавишами может выполнять другие команды.Клавиша Application (находится между кнопками WIN и CTRL справа) — равноценнаянажатию правой кнопки мыши.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота