Anechka6665
21.02.2021 01:05

Написать программу для нахождения величин S1,k1-сумма и количество элементов массива A(n) принадлежащих отрезку[a,b]
S2,k2-сумма и количество элементов массива B(m) не принадлежащих отрезку [c,d]
a,b,c,d-произвольные числа

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Miheevf
18.01.2021 22:17
Рассмотрим имеющиеся фрагменты, имея в виду, что полный адрес должен состоять из четырех натуральных чисел, не превышающих 255 и разделенных точками.
1. Рассмотрим фрагмент А (7.99):
После 99 или может следовать точка, или это должен быть последний фрагмент. Но у нас нет фрагментов, начинающихся с точки, поэтому остается только первый вариант и адрес принимает вид ххх.yyy.zz7.99
2. Рассмотрим фрагмент Б (31.7):
Если он стоит непосредственно перед А, получаем ххх.у31.77.99 и фрагмент 8.21 уже негде поставить. Если он стоит первым, получаем 31.7yy.z7.99, тогда место фрагмента 8.21 будет непосредственно перед 7.99 и мы получим адрес 31.7у8.217.99 и вставив на место у фрагмент В (2) получим недопустимый адрес 31.728.217.99. Следовательно фрагмент Б может быть только вторым, а фрагмент Г (8.21) - третьим: х31.78.217.99
3. По остаточному принципу фрагмент В (2) может быть только первым:
231.78.217.99

ответ: ВБГА
0,0(0 оценок)
Ответ:
алинаарсенова
14.09.2020 00:42
Program Dimamixali14;
uses crt;
const 
  n=10;
Var
  s:string;
  fly:text;
  a: array [1..n,1..n] of integer;
  i,j,k,summa: integer;
begin
  S:='*** Alphaeus is thinking... ***';
  for i:=1 to length(s) do begin
  write(s[i]);
  for j:=1 to 500000 do s[i]:=s[i];
  end;
  writeln();  writeln('***          OK             ***');
  writeln();  writeln('Задача:');
  writeln('Сформировать квадратную матрицу A(NxN), которую вывести. Строки с отрицательным элементом на главной диагонали последовательно записать в файл. В конец файла дописать сумму первой и последней компонент, файл отпечатать.');
  randomize;
  assign(fly,'F.txt');
  rewrite(fly);
{заполняем и выводим матрицу}
  writeln(); writeln('Matrix:');
  for i:=1 to n do begin
    for j:=1 to n do begin
      a[i,j]:=Random(101)-50;
      write (a[i,j]:3);
    end;
    writeln();
  end;
  writeln();writeln();
{заполняем файл}
  for i:=1 to n do begin
    for j:=1 to n do begin
      if(i=j) and (a[i,j]<0) then
        begin
          for k:=1 to n do
            write(fly,a[i,k]:3);
          writeln(fly, ' ');
        end;
    end;
   end;
  writeln();
  writeln('File:');
  summa:=a[1,1]+a[n,n];
  writeln(fly,'Summa = ',summa);
  s:='';
{выводим файл}
  reset(fly);
  while not eof (fly) do
  begin
    readln (fly, s);
    writeln(s);
  end;
  close(fly);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота