kvashenko403
12.11.2021 15:42

№1. Составить блок-схему, затем написать программу на языке Паскаль алгоритма, который получает на вход два числа, складывает их и выводит сумму на экран. Переменные – a, b – входные и sm – итоговая сумма. Программа должна напечатать в результате следующее: «Сумма числа такого-то и такого-то равна тому-то». №2. Написать программу на языке Паскаль, которая проверяет, последняя цифра в числе больше пяти, или нет. Программа должна вывести на экран одно из двух сообщений «Последняя цифра числа – такая-то и она больше 5», или «Последняя цифра числа – такая-то и она меньше 5». Переменные – а – вводимое число и с – последняя цифра.

№3. Написать программу на языке Паскаль, которая получает на вход двузначное число, меняет цифры в числе местами и выводит на экран новое, изменённое число. Переменные – а – входящее число и n – результат.
№4. Написать программу, которая складывает два числа и проверяет сумма их больше ста, или меньше. Переменные а, b – входящие числа и sm – сумма двух чисел. Программа должна напечатать «Сумма числа такого-то и такого-то равна тому-то и она больше/меньше 100».

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Аймания
18.03.2020 21:54
1. С=2*Pi*R, S= Pi*R^2, V=4/3*Pi*R^3, где Pi=3,14, заданный радиус R
2. P=a+b, S=1/2*a*b, где a и b - данные катеты
3. Пусть даны координаты трех вершин треугольника A(x1;y1), B(x2;y2), C(x3;y3).
Расстояние между двумя точками вычисляется по формуле
d= \sqrt{ ( x_{2} - x_{1} )^{2}+ ( y_{2} - y_{1} )^{2} }
Тогда периметр треугольника можно вычислить по формуле:
P=sqrt((x2-x1)^2+(y2-y1)^2)+sqrt((x3-x2)^2+(y3-y2)^2)+sqrt((x3-x1)^2+(y3-y1)^2).
Площадь треугольника по формуле Герона вычисляется по формуле:
s= \sqrt{p(p-a)(p-b)(p-c)}, где p= \frac{a+b+c}{2}-полу периметр треугольника.
S=sqrt((sqrt((x2-x1)^2+(y2-y1)^2)+sqrt((x3-x2)^2+(y3-y2)^2)+sqrt((x3-x1)^2+(y3-y1)^2)/2*(sqrt((x2-x1)^2+(y2-y1)^2)+sqrt((x3-x2)^2+(y3-y2)^2)+sqrt((x3-x1)^2+(y3-y1)^2)/2-sqrt((x2-x1)^2+(y2-y1)^2))*(sqrt((x2-x1)^2+(y2-y1)^2)+sqrt((x3-x2)^2+(y3-y2)^2)+sqrt((x3-x1)^2+(y3-y1)^2)/2-+sqrt((x3-x2)^2+(y3-y2)^2))*(sqrt((x2-x1)^2+(y2-y1)^2)+sqrt((x3-x2)^2+(y3-y2)^2)+sqrt((x3-x1)^2+(y3-y1)^2)/2-sqrt((x3-x1)^2+(y3-y1)^2))
4. Среднее геометрическое трех чисел вычисляется по формуле
\sqrt[3]{abc} или
(a*b*c)^1/3
0,0(0 оценок)
Ответ:
dodmitry
15.12.2022 14:04
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016 - №1
begin
  var a,b,c:integer;
  Write('Введите три натуральных числа: '); Read(a,b,c);
  var s:=a+b+c;
  var k:=Trunc(sqrt(s));
  if k*k=s then Writeln('Сумма чисел - квадрат ',k)
  else Writeln('Сумма чисел не является квадратом целого')
end.

Тестовое решение
Введите три натуральных числа: 13 4 8
Сумма чисел - квадрат 5

// PascalABC.NET 3.1, сборка 1230 от 27.04.2016 - №2
begin
  var a,b,c:integer;
  Write('Введите три натуральных числа: '); Read(a,b,c);
  var s:=power(a*b*c,1/3);
  if s=int(s) then Writeln('Среднее геометрическое - целое число')
  else Writeln('Среднее геометрическое - нецелое число')
end.

Тестовое решение
Введите три натуральных числа: 16 8 15
Среднее геометрическое - нецелое число
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота