Нужно написать программу В строке символов встречаются различные скобки: (), [], {}. Удалить символы, которые находятся между скобками и сами скобки.

На языке C/C++

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
supernogai
16.09.2021 19:11
#include <stdio.h>

int main(void) {
 int a1,a2,b,k1=0,k2=0;
 printf("a1 = ");
 scanf("%d",&a1);
 printf("a2 = ");
 scanf("%d",&a2);
 if (a1>0) b=a1; else b=-a1;
 while (b>0) {
  k1++; b /= 10;
 }
 if (a2>0) b=a2; else b=-a2;
 while (b>0) {
  k2++; b /= 10;
 }
 if (k1>k2) printf("В числе %d больше цифр, чем в числе %d",a1,a2);
 else if (k2>k1) printf("В числе %d больше цифр, чем в числе %d",a2,a1);
  else printf("Количество цифр в числах одинаково");
 return 0;
}

Пример:
a1 = 153
a2 = -4680
В числе -4680 больше цифр, чем в числе 153
0,0(0 оценок)
Ответ:
Murmurmur29
10.12.2021 16:03
Uses Crt;
  const n=5; m=7;
  type Mas = array [1..n, 1..m] of integer;
  var i, j, j1, j2: integer;
      Sumj1, Sumj2: real;
      A: Mas;
begin
 ClrScr;
 Randomize;
 SumJ1:=0; SumJ2:=0;
 for i:=1 to n do
    for j:=1 to m do
    A[i,j]:=random (10);
 WriteLn (' Massiv A: ');
 for i:=1 to n do
   begin
      for j:=1 to m do
      Write (A[i,j]:4);
      WriteLn;
   end; WriteLn;
 repeat
   Write (' Stolbez #1 = ');    ReadLn(j1);
 until (j1>=1) and (j1<=m);
 repeat
   Write (' Stolbez #2 = '); ReadLn(j2);
 until (j2>=1) and (j2<=m) and (j1<>j2);
 for i:= 1 to n do
    SumJ1 := SumJ1+A[i,j1];
 for i:= 1 to n do
   SumJ2:=SumJ2+A[i,j2];
 SumJ1:=SumJ1/n; SumJ2:=SumJ2/n; 
WriteLn;
WriteLn (' Srednee stolbza ', j1, ' = ', SumJ1:4:2);
WriteLn (' Srednee stolbza ', j2, ' = ', SumJ2:4:2); 
ReadLn;
end.
Паскаль.составить программу, вычисляющую среднее значение по двум столбцам матрицы. номера столбцов
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота