лето1990
31.01.2021 08:25

Написать программу на языке Си (Не С++), падение снега (3 вида снежинок), используя данные библиотеки: string.h stdio.h stdlib.h Чтобы работало в онлайн компиляторе

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Vikak005love
11.10.2021 02:42
Для начала следует отметить тот факт, что не следует путать оператор присваивания со знаком равенства в математике.
Оператор присваивания работает следующим образом. (на примере k := 4+7) Сначала вычисляется значение выражения справа от оператора (4+7 = 11), затем результат вычисления "записывается" в переменную из левой части оператора. В результате по имени этой переменной можно получить записанное значение и даже использовать его в других выражениях.

"а := 17" Записываем в переменную а значение 17.

"b := 23" Записываем в переменную b значение 23.

"b := а + b + 1" Сначала вычисляем выражение a+b+1 = 17+23+1 = 41. Затем изменяем значение переменной b (теперь она хранит в себе 41)

"а := b + а" Сначала вычисляем выражение b+a = 41+17 = 58. Затем изменяем значение переменной a (теперь она хранит в себе 58)

ответ: 58
0,0(0 оценок)
Ответ:
daniilbabics
29.09.2022 21:52
Хром жрет переносы строк - сейчас поправлю

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
namespace replaceThis{
 class main{
  static void Main(){
   int N = 10;
   int[] arr = new int[N];
   Random rand = new Random();
   Console.Write("Исходный   массив: ");
   for (int i = 0; i < N; ++i){
    arr[i] = rand.Next(1, 9);
    Console.Write("{0} ", arr[i]);
   }
   Console.WriteLine("");
   int maxI, minI;
   maxI = minI = 0;
   for(int i = 1; i< N; ++i){
    if (arr[maxI] < arr[i])
     maxI = i;
    if (arr[minI] > arr[i])
     minI = i;
   }
   int  temp = arr[minI];
   arr[minI] = arr[maxI];
   arr[maxI] = temp;
   Console.WriteLine("Индекс максимального - {0}. Индекс минимального - {1}.", maxI, minI);
   Console.Write("Измененный массив: ");
   for (int i = 0; i < N; ++i)
    Console.Write("{0} ", arr[i]);
   Console.ReadKey();
  }
 }
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота