тата282
01.12.2020 03:06

Составить программу на паскале: Стоимость проезда на поезде составляет 150руб за одну зону, нумерация ведётся с городского вокзала. Составить программу, которая определяла бы стоимость проезда в 1 проезд между станциями, расположенными в разных зонах. Номер зоны, в которой находится станция отправляется и той зоны, в которой расположена конечная станция вводится с клавиатуры. При составлении программы необходимо учесть, что пассажир может отправляться как из города в пригород, так и назад. Усовершенствовать программу, которая вычисляет стоимость проезда в пригородном поезде так, чтобы она выводила на экран меню, предлагающее следующие варианты: 1-стоимость поездки в 1 конец; 2-вычисление стоимости поездки в оба конца; 3-вычисление стоимости месячного билета (стоимость - стоимость поездки, умноженная на 15).

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Foksit2006
12.06.2021 08:05
Var   i, n:integer; b:array[1..3] of integer;begin    write('Type integer: ');    readln(n);    if n<0 then        n:=-n; // уничтожение знака числа     repeat    i:= i + 1;        b[i] := (n mod 10); // вывод последней цифры числа        n:= n div 10; // удаление последней цифры числа    until n=0;    if b[3] > b[2] thenwriteln('Цифра сотен больше десятков ',b[3] - b[2])elsewriteln('Цифра сотен меньше десятков ',b[2] - b[3]);if b[2] > b[1] thenwriteln('Цифра десятков больше единиц ',b[2] - b[1])elsewriteln('Цифра десятков меньше единиц ',b[1] - b[2]);end.
0,0(0 оценок)
Ответ:
Rita53
21.02.2023 02:05
Var N, k, digit, prod: longint;
begin
  readln(N);
  prod := 1; // Произведение не должно быть равно 0, в вашем случае просто отделают последнюю цифру, не проверяя ее кратна она 3 или нет
  k := 0;
  while (N > 0) do 
  begin
    digit := N mod 10;
    if (digit mod 3 = 0) and (digit<>0) then begin // (digit<>0) проверка на неравенство нулю(любое число*0=0)
    prod := prod*digit;
    k := k+1;
    end;
    N := N div 10;
  end;
  if (k = 0) 
  then writeln('NO')
  else writeln(prod) // Выводить нужно не конечное N, а именно произведение(prod)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота