опчарготь
08.10.2020 01:17

Написать программу, которая создает на рабочем столе файл с названием proverka.txt и записывает в него фразу "Я люблю паскаль"

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
gazelle116
14.11.2022 08:58

ЦЕЛЬ ПРОЕКТИРОВАНИЯ ПРОГРАММЫ:  

Автоматизация расчетов материалов, необходимых для выпол-нения ремонта в доме или квартире.  

НАЗНАЧЕНИЕ ПРОГРАММЫ:  

Расчет количества рулонов обоев для указанной комнаты.  

ОБЛАСТЬ ПРИМЕНЕНИЯ ПРОГРАММЫ:  

Программа может быть использована при ремонте комнаты, ко-гда надо знать, сколько надо купить рулонов обоев.  

ВВОД  

Вводится высота от пола до потолка, длина большей стены, длина меньшей стены, ширина двери, высота двери, ширина оконного проема, высота оконного проема, длина руло-на(const1) и ширина рулона(const2).  

ВЫВОД  

Выводится количество рулонов n

Объяснение:

0,0(0 оценок)
Ответ:
Mauntians
06.11.2021 07:28
Import java.util.*; import java.lang.*; import java.io.*; class MyLab { public static void main (String[] args) { int a; //первое число, от которого начнем int b; //второе число, до которого будем считать произведение int product; //произведение всех целых чисел Scanner in; //с этого объекта читаем ввод с клавиатуры in = new Scanner(System.in); System.out.println("Enter A: "); a = in.nextInt(); System.out.println("Enter B: "); b = in.nextInt(); if (a > b) //если число от которого начинаем больше чем до которого нужно считать - поменять их местами { int buf = a; //сохраняем значение a a = b; //присваиваем переменной a значение переменной b b = buf; //присваиваем переменной b значение сохраненной в buf переменной a } product = 1; //инициализируем 1, что бы получить корректное произведение (ни в коем случаи не 0м, если вы не понимаете почему именно 1, то вам нечего делать в программировании, без обид) for (int i = a; i <= b; ++i) //цикл, повторяем на промежутке от a до b с шагом в 1 { product *= i; //умнажаем текущее значение произведения всех целых чисел на текущее целое число } System.out.printf("Product of all integer numbers from A = %d, to B = %d, is = %d\n", a, b, product); } }
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота