angelenok1840
21.05.2021 06:40

Напишите программу которая выводит на экран четные числа от 71 до 57 в порядке убывания На ПАЙТОНЕ

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Jika030302
27.12.2022 06:18

// C# 7.3

using System;

using System.Collections.Generic;

using System.Collections;

using System.Text;

namespace Rextester

{

   public class Program

   {

       public static void Main(string[] args)

       {

           var crypted = "";

 

           for (int i = 0; i < CaesarCipher.Ru.Length; i++)

               Console.WriteLine(CaesarCipher.Decode(i, crypted));

       }

   }

   

   class CaesarCipher

   {

       public static readonly string Ru = "";

       public static readonly string RuD = "";

       private static readonly int defaultStep = 3;

       public static CaesarEncrypted Encode(int step, string source, Func<string, string> translate)

       {

           string translatedData = translate(source);

           var stringBuilder = new StringBuilder();

           foreach (char c in translatedData.ToLower())

           {

               stringBuilder.Append(RuD[Ru.IndexOf(c) + step]);

           }

           return new CaesarEncrypted(step, stringBuilder.ToString());

       }

       public static CaesarEncrypted Encode(int step, string source)

       {

           return Encode(step, source, x => x);

       }

       public static string Decode(CaesarEncrypted source)

       {

           var step = source.Step;

           return Encode(-step + Ru.Length, source.ToString(), x => x);

       }

       public static string Decode(int step, string source)

       {

           return Encode(-step + Ru.Length, source, x => x);

       }

   }

   class CaesarEncrypted : IEnumerable, IEnumerable<char>

   {

       public int Step { get; set; }

       public string Data { get; set; }

       public CaesarEncrypted(int step, string initData)

       {

           Step = step;

           Data = initData;

       }

       public CaesarEncrypted(string initData) : this(int.MaxValue, initData)

       {}

       public IEnumerator<char> GetEnumerator()

       {

           foreach (char c in Data)

               yield return c;

       }

       IEnumerator IEnumerable.GetEnumerator() => (IEnumerator<char>)GetEnumerator();

       public override string ToString() => Data;

       public static implicit operator string(CaesarEncrypted source) => source.ToString();

   }

}

0,0(0 оценок)
Ответ:
ulyanaKnyazeva10
28.03.2020 19:55
После коррекции уровней внешний вид фотографии значительно улучшается, она становится более контрастной, содержит достаточно большое число и светлых, и тёмных пикселей. Однако гистограмма после коррекции не сплошная, а состоит из отдельных полосок (см. рис. 8.8). Это значит, что пикселей с некоторыми значениями яркости нет совсем (подумайте почему).

Заметим, что над гистограммой в окне Уровни расположен выпадающий список, в котором можно выбрать для коррекции один цветовой канал: красный, синий или зелёный. Это даёт возможность настраивать каждый канал отдельно.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота