Dina333098
10.04.2020 17:34

Нужно написать программу на языке паскаль по условию: найти сумму элементов массива расположенных до последнего положительного элемента буду бескрайне , если мне))

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Софи1138
10.07.2020 18:30
Uses crt;
var a,b:array[1..100] of integer; i,j,k,n:integer;
procedure rmassr;
begin
    for i:=1 to n do begin
        a[i]:=random(10);
    end;
end;
procedure rmassy;
begin
    for i:=1 to n do begin
        readln(a[i]);
    end;
end;
procedure rmass();
begin
    for i:=1 to n do begin
        write(a[i],' ');
    end;
end;
procedure newmass;
begin
    for i:=1 to n do begin
        if a[i] > 0 then b[i]:=a[i];
    end;
    for i:=1 to n do begin
        j:=j+b[i];
    end;
    writeln('summa = ',j);
end;
begin
clrscr;
randomize;
write('длина массива '); readln(n);
write('1-random; 2-в ручную'); readln(k);
if k = 1 then
    rmassr()
else rmassy();
rmass();
writeln();
newmass();
readln
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота