Djamila1108
18.12.2020 00:30

Нужно написать программу в паскале найти наименьшее общее кратное n натуральных чисел, используя алгоритм евклида.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
KILLER435
12.07.2020 13:53
Var i, a, b, t, d, n : integer;
x : array of integer;
begin
    read(n);
    SetLength(x, n + 1);
    for i := 1 to n do
        read(x[i]);
    a := x[1];
    for i := 2 to n do begin
        b := x[i];
        d := a * b;
        while (b > 0) do begin
            t := a;
            a := b;
            b := t mod b;
        end;
        a := d div a;
    end;
    writeln(a);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота