Нурюс
28.09.2021 05:35

Написать программу вычисления стоимости некоторого количества (по весу) яблок. ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены полужирным шрифтом). вычисление стоимости покупки. введите исходные данные: цена одного килограмма яблок (руб.) = 8.5 вес яблок (кг) = 2.3 стоимость покупки: 19.55 руб.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Natashakr10
13.07.2020 19:13
Var x,y:real;
begin
writeln('Вычисление стоимости покупки.');
writeln('Введите исходные данные:');
writeln('Цена одного килограмма яблок  (руб) = ',x);
writeln('Вес яблок (кг) = ',y);
writeln('Стоимость покупки: ',x*y,' руб.');
end.
0,0(0 оценок)
Ответ:
fan211
11.01.2024 12:09
Хорошо, давайте напишем программу для вычисления стоимости покупки яблок.

1. Сначала необходимо объявить переменные, которые будут хранить значения цены одного килограмма яблок и веса яблок. Для этого можем использовать тип данных float, так как цена может содержать дробную часть.

```python
price_per_kg = 8.5 # Цена одного килограмма яблок
weight = 2.3 # Вес яблок
```

2. Далее, чтобы вычислить стоимость покупки, нужно перемножить цену за килограмм на вес. Результат можно сохранить в новую переменную с названием total_cost.

```python
total_cost = price_per_kg * weight
```

3. Наконец, нужно вывести результат на экран, чтобы пользователь мог увидеть стоимость покупки. Для этого используем функцию print и строковое форматирование для вывода значения переменной total_cost.

```python
print("Стоимость покупки: " + str(total_cost) + " руб.")
```

Общий код программы будет выглядеть следующим образом:

```python
price_per_kg = 8.5 # Цена одного килограмма яблок
weight = 2.3 # Вес яблок

total_cost = price_per_kg * weight

print("Стоимость покупки: " + str(total_cost) + " руб.")
```

Когда вы запустите эту программу, она попросит вас ввести цену одного килограмма яблок (8.5) и вес яблок (2.3). После того, как вы введете значения, программа вычислит стоимость покупки (19.55) и выведет ее на экран.

Надеюсь, что я смог ясно объяснить и продемонстрировать решение этой задачи. Если у вас возникнут какие-либо вопросы, пожалуйста, не стесняйтесь задавать их.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота