Skvaler
07.01.2021 19:32

Написать программу, определяющую, принадлежит ли точка с координатами (x,y) кольцу с центром (x0,y0). r1 и r2 соответственно радиусы внутренней и внешней окружностей, образующих кольцо.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Farys
02.10.2020 04:12
Var  x,y,r1,r2:real;
begin
write('Введите x, y, внутренний радиус, внешний радиус: ');
readln(x,y,r1,r2);
if (x*x+y*y<=r2*r2) and (x*x+y*y>=r1*r1) then
  writeln('Да, принадлежит')
  else writeln('Нет, не принадлежит');
end. 
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота