Viviccompany
15.03.2020 09:53

Написать программу, которая считает и выводит на экран сумму всех целых чисел из промежутка [a, b]. числа a и b задает пользователь. программу реализовать с трех циклических алгоритмов: 1) цикл со счетчиком for 2) цикл с предусловием while 3) цикл с постусловием repeat в программе предусмотреть ситуацию, когда пользователь вводит значение b ‹ a пример 1: пользователь вводит числа a=5, b=10. сумма чисел: 5+6+7+8+9+10. вывод на экран: 45 пример 2: пользователь вводит числа a=7, b=4. сумма чисел: 4+5+6+7. вывод на экран: 22 пример 3: пользователь вводит числа a=5, b=5. сумма чисел: 5. вывод на экран: 5

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
peskovaedoz45yo
02.10.2020 04:58
program Cikle;
uses crt;
var a,b,i,k:integer;
Begin
clrscr;
write('Введите А: '); readln(a);
write('Введите B: '); readln(b);
if a>b then begin i:=a; a:=b; b:=i end;
{}
реализации - цикл for}
k:=0;
for i:=a to и do k:=k+i;
{}
реализации - цикл с предусловием while}
k:=0;
while a<=b do begin
k:=k+a;
a:=a+1 end;
{}
цикл с постусловием repeat}
k:=0;
repeat
k:=k+a;
a:=a+1;
until a>b;
{}
{Окончание программы одинаковое для всех
Writeln('Сумма элементов в интервале [A;B] равна ', k)
readln
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота