umos
27.10.2022 15:35

Составить программу в паскаль: дано число меньше 16 определить - сколько единичных битов содержит двоичная запись этого числа.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Sam223225
21.07.2020 12:09
Var b,a,c,kol:integer;
 begin 
writeln('введите число в десятичной системе счисления');
 readln(a); 
 kol:=0; 
 while(a>=2) do  begin 
      c:=a div 2; 
      b:=2*c; 
      b:=a-b; 
      writeln(b); 
      a:=c; 
     if a<2 then 
     writeln(a); 
     if a > 0 then 
     kol:=kol+1; 
end; 
writeln('количество 'kol);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота