sashademidova12345
15.12.2020 06:25

С) turbo pascal составить программу к : 'числа a,b и c называются "пифагоровой тройкой",если выполняется условие a*a+b*b=c*c отыщите все пифагоровы тройки среди чисел от 1 до n

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Dmitrrrr
02.10.2020 12:56
Вот решение за O(n^3)
var
n,i,j,z:longint;

begin
read(n);

for i:=1 to n do
 for j:=1 to n do
  for z:=1 to n do
   if (i*i+j*j=z*z) then writeln(i,' ',j,' ',z);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота