Zhuravl220
25.05.2023 17:42

Написать программу на языке паскаль. преобразовать массив таким образом, чтобы в первой его половине располагались элементы, стоявшие в четных позициях, а во второй половине - элементы, стоящие на нечетных позициях.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Cole21
16.09.2020 14:24
Const n=20;
var a: array[1..n] of integer;
    tmp,i,j,m: integer;
begin
{ заполнение массива и вывод на экран }
  for i:=1 to n do
  begin
     a[i]:=Random(100);
     write(a[i],' ');
   end;
  { преобразование массива}
  m:= n div 2;
  for i:=1 to m do
  begin
    tmp:=a[i];
    a[i]:=a[2*i];
    for j:=2*i-1 downto i+1 do a[j+1]:=a[j];
    a[i+1]:=tmp;
  end;
  writeln;
  writeln('преобразованный массив');
{ вывод массива на экран }
  for i:=1 to n do write(a[i],' ');
end.
 
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота