dianabalaganska
21.06.2022 07:34

1) составьте программу, которая заполняет массив а[1..20] случайными целыми числами в диапазоне от 1 до 10 и находит среднее арефметическое элементов с четными значениями и нечетными индексами.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
yyyye
25.08.2020 07:17
Если надо найти ср. арифметическое одновременно и четных чисел и нечетных индексов:

var
a:array[1..20] of integer;
i, k, s: integer;
begin
for i:=1 to 20 do begin
a[i]:=random(1,10);
if (a[i] mod 2=0)or(i mod 2<>0) then begin
k:=k+1; s:=s+a[i]; end; end
writeln((s/k):17:2);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота