Lena89269295717
21.12.2022 19:49

Составить программу возведения натурального числа в квадрат, используя следующую закономерность: i2 =1 2 2=1+3 з2 =1 + 3 + 5 42=1+3+5+7 п2 = 1 + 3 + 5 + 7 + 9 + . . + 2 п - 1 программа pascal

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
lilo2622
25.08.2020 09:19
Всё до безобразия просто: 

var n:integer; nn:real;
begin
  write('Введи число: ');
  readln(n);
  for var i:=1 to n do nn:=nn+(2*i-1);
  writeln(n,'^2=',nn);
end.  
0,0(0 оценок)
Ответ:
fheeubeujdshebj
25.08.2020 09:19
Function MySQR(n : Integer) : Integer;
Begin
  If n>1 then MySQR:=n+MySQR(n-2) else MySQR:=1;
end;

Var a : Integer;
Begin
  Readln(a);
  Writeln(MySQR(a*2-1));
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота