BREYKER
03.08.2020 18:58

Составьте программу перевода двоичной записи натуральных чисел в десятичную.(в pascal abc)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
nik123580
19.08.2020 15:13
Var i: integer;
    n,k: int64;
    s: string;
begin
  write('двоичное число:  ');  readln(s);
  k:=1;  n:=0;
  for i:=length(s) downto 1 do
  begin
    n:=n+(ord(s[i])-48)*k;
    k:=k*2;
  end;
  writeln('десятичное число:  ',n);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота