Войти
Регистрация
Спроси ai-bota
MelissaRacoon
10.02.2020 11:59
Язык c. дан одномерный массив, заменить элементы больше данного z этим числом. посчитать кол-во замен.
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Денисс2017
17.03.2022 03:11
Объем звукового аудиофайла 750 кбайт частота дискретизации 32 кгц длительность звучания этого файла 12 секунд определите глубину звука...
WFCPDF
26.04.2021 13:30
Найдите в Интернете с любой поисковой системы материал по прикладному программному обеспечению. Составляйте за различными добейтесь такого результата, при котором поисковая...
antochakakaka
14.07.2021 11:28
сделать по информатике контрольную...
1649fn49
24.06.2021 13:14
прибор для измерения разной информации (температуры,скорости,излучения,цвета,звука)3буква т, всего6букв,4класс...
Закфаныалға
16.05.2021 08:42
К пятизначному натуральному числу применяется следующий алгоритм: 1) вычислить сумму первых двух цифр; 2) вычислить сумму последних трёх цифр; 3) записать полученные...
VikaSh86
02.08.2020 08:45
Маша изучает логические операции and и or. ей разобраться для каких из указанных чисел верно логическое условие (в числе меньше восьми цифр) and ((число кратно 3) or...
perizatttt
22.05.2021 22:28
После выключения компьютера пропадает информация находящаяся на...
iruha07082001
04.05.2023 19:47
Скласти доповідь безпека дітей в інтернеті 6-7речень мінімум ...
мася277
10.03.2021 09:54
Напишите программу,которая выводит на экран таблицу квадратов первых двадцати целых положительных четных чисел....
РумакСтепан
25.01.2020 13:34
Тема От Средневековья к Новому времени...
Ответ:
Анастасия105
03.10.2020 09:56
#include <iostream>
#include <vector>
#include <cstdlib>
using namespace std;
int main()
{
int count;
cout <<"Введите размер массива: ";
cin >>count;
vector<int> v(count);
srand(time(0));
for (int i=0; i<count; i++)
{
v[i]=rand()%100;
cout <<v[i] <<" ";
}
cout <<endl;
int c=0;
int n;
cout <<"Введите максимальный элемент: ";
cin >>n;
for (int i=0; i<v.size(); i++)
if (v[i]>n)
{
v[i]=n;
c++;
}
cout <<"Было произведено " <<c <<" замен" <<endl;
for (int i=0; i<v.size(); i++)
cout <<v[i] <<" ";
cout <<endl;
return 0;
}
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота