antonuku977
16.11.2020 01:02

Написать программу заполнения массива случайными числами из диапазона от -20 до 20 и вывода порядковых номеров четных чисел

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
міхан
24.09.2020 01:47
Var a:array of integer;   
      i,n:integer;
begin
//Заполняем массив сл. числами и выводим
//Нумерация массива с 0
write('Число элементов массива ');readln(n);
setlength(a,n);
for i:=0 to n-1 do begin
  a[i]:=random(41)-20;
  write(a[i]:4);
end;
writeln;
//Вывод номеров четных элементов
for i:=0 to n-1 do
  if a[i] mod 2 = 0 then writeln(a[i]:4, ' номер: ',i );
end.

Тестовое решение:
Число элементов массива 10
  -5  14   3  13   4   1  18   7  12 -14
  14 номер: 1
   4 номер: 4
  18 номер: 6
  12 номер: 8
 -14 номер: 9
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота