physikman
23.02.2020 03:49

На паскале. вводятся координаты x, y для n точек. определите, сколько точек в круг радиуса r. сколько точек в кольцо с меньшим радиусом r1, большим r2.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ученикB
24.09.2020 18:59
Var x,y,R,R1,R2,rt:real;i,N,k,m :integer;begin

R:= 15; R1:= 12; R2:=25;write('Введите N'); Read(N); 

for i:=1 to N do beginwrite('Введите координаты х и у'); Read(x,y);rt:=sqrt(sqr(x)+ sqr(y));writeln('r =':3,rt:6);

if rt < R then k:= k + 1;

if (rt < R2) and (rt > R1) then m:= m + 1;

end;writeln; writeln('Количество точек в кругу с радиусом R = ',k);writeln('Количество точек в кольце = ',m);end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота