kristina1861
27.09.2022 14:41

Вмассиве [1..30} замените все отрицательные числа на 5, а оставшиеся на 2. желательно сделать через цикл for и написать программу.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Karinakotik200165
03.10.2020 14:29
Const n=30; 
var a:array[1..n] of integer;
i:integer; 
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do
 begin
 a[i]:=random(21)-10;
 write(a[i]:4);
 end;
writeln;
writeln('Измененный массив:');
for i:=1 to n do
 if a[i]<0 then a[i]:=5 else a[i]:=2;
for i:=1 to n do write(a[i]:4);
writeln;
end.

Пример (для n=10):
Исходный массив:
  -2   6  -4   7  -4   4  -9   5   2   1
Измененный массив:
   5   2   5   2   5   2   5   2   2   2
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота