100π100
31.07.2020 11:58

Напишите программу, которая возводит введенное число в степень 10, используя только четыре операции умножения. на си

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
hychkairyna
28.09.2020 16:23
#include <cstdio>
long long ans, a;
int main()
{
  scanf("%lld", &a); //считываем исходное число
  a *= a; //возводим исходное число в квадрат
  ans = a; //в ответе хранится квадрат исходного числа
  a *= a; //в a хранится 4 степень исходного числа
  a *= a; //в a хранится 8 степень исходного числа
  ans *= a; //2 степень исходного числа умножаем на 8 степень
  printf("%lld", ans); //выводим ответ
  return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота