Усварппоры
12.07.2022 10:32

Мне нужно ответь составить программу, которая бы запрашивала хнач , хкон , шаг c и определяла сумму всех отрицательных чисел от хнач до хкон с шагом с (решить , используя цикл с постусло-вием – repeat … until).

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Никитка90909
03.10.2020 18:47
//Pascal ABC.NET 3.1 сборка 1256

Var
 n,k,c,s,kar:real;
 i:integer;
begin
read(n,k,c);
i:=0;
s:=0;
kar:=n;
repeat
if n<0 then s:=s+n;
inc(i);
n:=kar+i*c;
until n>k;
writeln(s);
end.

Пример ввода:
-3
1
1.1
Пример вывода:
-5.7

Мне нужно ответь составить программу, которая бы запрашивала хнач , хкон , шаг c и определяла сумму
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота