yyydomayyy
28.09.2020 14:04

Нужно написать программу для сокращения дроби, используя алгоритм евклида

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
09alan
07.09.2021 23:42
9 + 9 + 9 = 27, при вводе числа, больше 27 будут выведены все трёхзначные числа.

Procedure ABC(A:integer);
Var i:integer;
Begin
For i:= 100 to 999 do
    if (i div 100)+((i div 10) mod 10)+(i mod 10)<=A then
       Write(i,' ');
End;
Var A:integer;
Begin
Write('Введите целое число: ');
ReadLn(A);
ABC(A)
End.

Пример:

Введите целое число: 7
100 101 102 103 104 105 106 110 111 112 113 114 115 120 121 122 123 124 130 131 132 133 140 141 142 150 151 160 200 201 202 203 204 205 210 211 212 213 214 220 221 222 223 230 231 232 240 241 250 300 301 302 303 304 310 311 312 313 320 321 322 330 331 340 400 401 402 403 410 411 412 420 421 430 500 501 502 510 511 520 600 601 610 700
0,0(0 оценок)
Ответ:
lisa285
07.09.2021 23:42
9 + 9 + 9 = 27, при вводе числа, больше 27 будут выведены все трёхзначные числа.

Procedure ABC(A:integer);
Var i:integer;
Begin
For i:= 100 to 999 do
    if (i div 100)+((i div 10) mod 10)+(i mod 10)<=A then
       Write(i,' ');
End;
Var A:integer;
Begin
Write('Введите целое число: ');
ReadLn(A);
ABC(A)
End.

Пример:

Введите целое число: 7
100 101 102 103 104 105 106 110 111 112 113 114 115 120 121 122 123 124 130 131 132 133 140 141 142 150 151 160 200 201 202 203 204 205 210 211 212 213 214 220 221 222 223 230 231 232 240 241 250 300 301 302 303 304 310 311 312 313 320 321 322 330 331 340 400 401 402 403 410 411 412 420 421 430 500 501 502 510 511 520 600 601 610 700
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота