rid843
11.03.2023 14:55

Напишите программу. и блок-схему. вводится массив из 15 элементов,нужно определить сколько эл. массива будут между его макс и миним. элементом.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Marik19782002
09.09.2020 02:07
Uses crt;
const  n = 15;
var  i, imin, imax, m, min, max, j: integer;
  a: array[1..n]of integer;
begin 
Writeln('Введите числа в массив'); 
for i := 1 to n do   
readln(a[i]); 
for i := 1 to n do   
write(a[i], '   '); 
min := a[1]; 
max := a[1]; 
imin := 1;
imax := 1;  
for j := 1 to n do 
begin   
if(a[j] > max) then  
begin    
max := a[j];     
imax := j;   
end;   
if(a[j] < min) then   
begin     
min := a[j];     
imin := j;   
end; 
end; 
writeln(); 
writeln('индекс минимального элемента ', imin, ' индекс максимального элемента ', imax); 
m := abs(imin - imax); 
Writeln(); 
Writeln('Кол-во элементов между макс. и мин. элементами ', m - 1);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота