Alniri
18.02.2021 06:27

Вмассив сохранены результаты выполнения контрольной работы: 1)подсчитать количество пятёрок 2)определить средней за к/р 3)определите количество учеников,подучивших за к/р выше среднего

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
кирил2088
05.10.2020 22:25
Program n1;
const n=15;
var a: array[1..n] of integer;
i,k5,kns,sum: integer;
sb: real;
begin
randomize;
k5:=0;
kns:=0;
sum:=0;
write('оценки: ');
for i:=1 to n do
begin
a[i]:=random(4)+2;
write(a[i],' ');
if a[i]=5 then k5:=k5+1;
sum:=sum+a[i];
end;
writeln;
sb:=sum/n;
writeln('кол-во 5: ',k5);
writeln('ср арифм: ',sb);
for i:=1 to n do if a[i]>sb then kns:=kns+1;
writeln('кол-во уч >ср арифм: ',kns);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота