lol1047
17.05.2022 00:10

Написать программу на с++ 3. известен факториал числа (вводится с клавиатуры). найти это число.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
LEHA6712
07.10.2020 03:20
1.
#include <iostream>
using namespace std;

int main()
{
    int f, n, p;
    cin >> f;
    n = 0;
    p = 1;
    while (p<f) {
    n++;
    p*=n;
    }
    if (p==f) cout << n;
    else cout << "Ошибка ввода";
    system("pause");
}

2.
#include <iostream>
using namespace std;

int main()
{
    int f, n, p;
    cin >> f;
    p = 1;
    for (n=1; p<f; n++) p*=n;
    if (p==f) cout << n-1;
    else cout << "Ошибка ввода";
    system("pause");
}

Пример:
120
5
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота