WeReWolF47
16.01.2022 11:42

Составьте программу паскаль для нахождения всех счастливых автобусных билетов чтобы из низ извлекался квадратный корень

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
anyakhrebtova
08.10.2020 16:00

Программа, которая сравнивает первые 3 со вторыми 3мя ниже, но я не понял к чему было упоминание корня в первоначальном задании

Program bilet;
var

a,b,c:longint;
i:byte;
begin
writeln('vvrdite nomer');
readln(a);
b:=0;
c:=0;
for i:=1 to 6 do
    if i<4 then begin
       b:=b+(a mod 10);
       a:=a div 10;
       end
    else begin
         c:=c+(a mod 10);
         a:=a div 10;
    end;
if b=c then writeln('schastlivuy ',c,' = ',b)
else writeln('uvyu ',c,' <> ',b);
readln;
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота