26032004й
04.06.2022 05:04

1)дан одномерный массив. положительные элементы уменьшить в два раза, отрицательные заменить их индексами. 2)дан одномерный массив. найти произведение элементов массива. паскаль написать программу если можно блок схему

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Kira25112016
07.10.2020 13:22
//Pascal
//Массивы размеров 10 элементов заполняются случайными числами от -10 до 10

//1
var
  A: array[1..10] of real;
  i: byte;
begin
randomize;
writeln('Исходный массив.');
for i := 1 to 10 do
begin
  A[i] := random(21)-10;
  write(A[i]:5);
end;
writeln;
writeln('Измененный массив.');
for i := 1 to 10 do
begin
  if A[i] > 0 then A[i] := A[i] / 2
  else A[i] := i;
  write(A[i]:5);
end;
writeln;
end.

//2
var
  A: array[1..10] of integer;
  i: byte;
  mult: longint;
begin
mult := 1;
randomize;
writeln('Исходный массив.');
for i := 1 to 10 do
begin
  A[i] := random(21)-10;
  mult := mult * A[i];
  write(A[i]:5);
end;
writeln;
writeln('Произведение элементов массива = ', mult);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота