leda5
18.03.2021 01:46

Составьте программу вычисления среднего арифметического отрицательных элементов массива c++

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Koko2010007
09.10.2020 06:35

#include <iostream>

#define _ std::

int main()  {

int *a = new int[100];

int n, sum=0, c=0;

_ cin >> n;

for (int i = 0; i < n; i++) {

 _ cin >> a[i];

 if (a[i] < 0) {

  sum += a[i];

  c++;

 }

}

_ cout << (c != 0 ? (double)sum / c : 0)<<_ endl;

   return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота