dasha148ttt
14.01.2022 14:01

Составьте программу в паскаль для вычисления: найти радиус окружности, описанной около правильного n-угольника со стороной а

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Beleklera75
10.10.2020 00:56

var

   n : integer; // количество сторон (углов)

   a : integer; // длина стороны

   

begin

   write('введите количество сторон n= ');

   readln(n);

   write('введите длину стороны a= ');

   readln(a);

   writeln('радиус описанной окружности R=', a/2*(sin(pi/n)));

end.

не забываем что паскаль считает в радианах и формула расчета соответственная...

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота